First time woes.

Just starting out and need some advise? then post it in here.

First time woes.

Postby pommielad39 » Tue Aug 31, 2021 1:44 pm

Hey all,

I just started my first ever run on anything bigger than an airstill. I have a 35lt Digiboil, with a 'unwelcome advertiser' reflux column. Yesterday, I got everything set up, running a TPW, I had pretty specific instructions from a guy on FB distilling group.

Set boiler temp to 105*C, once column temp reached 30, I turned off 500W element and just used 1900W. Column temp hit 70, so I turned on the tap and waited for temp to stabilise, supposedly between 70 and 78*C, but it didn`t, it just kept rising and I had steam/vapour coming out of the top of the column. I`m at a bit of a loss as to what I did wrong(obviously something), any ideas as to where I messed up? TIA.
pommielad39
 
Posts: 8
Joined: Thu Mar 05, 2020 11:03 am
equipment: Reflux condenser on 50L keg boiler.

Re: First time woes.

Postby howard » Tue Aug 31, 2021 2:17 pm

sounds like you either you overpowered the condenser using the 1900w element or/and your water supply was too hot or not enough water flow.
i only use about 1500w on my 35l brewzilla.
maybe you need to consider a voltage controller :think:

edit maybe a bit more info/pic of your still will get some good advice, i am guessing :smile:
Last edited by howard on Tue Aug 31, 2021 2:19 pm, edited 1 time in total.
howard
 
Posts: 174
Joined: Fri Jul 17, 2020 12:53 am
Location: perth
equipment: 35l brewzilla
2" modular CM
gin caddy
changeover element switch and voltage controller on brewzillas 1900w element.
5L glass boiler/glass leibig

Re: First time woes.

Postby The Stig » Tue Aug 31, 2021 3:04 pm

I’m guessing an Alcoengine.
Not enough water flow and too much heat
The Stig
Site Nerd
 
Posts: 10160
Images: 9
Joined: Sun Jun 19, 2011 8:37 am
equipment: Only the Best will Do.
Mac4 SSG Bubbles of Joy

Re: First time woes.

Postby pommielad39 » Tue Aug 31, 2021 3:43 pm

Here`s some pics of my set up.
You do not have the required permissions to view the files attached to this post.
pommielad39
 
Posts: 8
Joined: Thu Mar 05, 2020 11:03 am
equipment: Reflux condenser on 50L keg boiler.

Re: First time woes.

Postby The Stig » Tue Aug 31, 2021 5:42 pm

Yummy , all that plastic :happy-partydance:
Seriously , ditch the plastic tube and collection jug .
The Stig
Site Nerd
 
Posts: 10160
Images: 9
Joined: Sun Jun 19, 2011 8:37 am
equipment: Only the Best will Do.
Mac4 SSG Bubbles of Joy

Re: First time woes.

Postby BlasphemousB » Tue Aug 31, 2021 6:52 pm

Yup by the looks of it you were using a submersible pump in that 44gal drum. How cold was that water when you started? If you're cycling it back in you not going to be able to knock down the temperature enough.

Also, I start the condenser water once the power to the boiler is connected and only turn the water off again after the power is turned off on the boiler and I'm packed up for the day. (Call it overly cautious but alcohol vapour is nasty stuff)
BlasphemousB
 
Posts: 26
Joined: Fri Aug 13, 2021 7:23 pm
Location: Melbourne
equipment: 3" 5 Plate Bubbler (glass and modular) on a 35L Brewzilla

Re: First time woes.

Postby BigRig » Tue Aug 31, 2021 9:15 pm

You're right blasphemous, the alcoengine condenser is definitely on the small side.

Pommielad, If u wait to 70c to turn on the water you have gone too far. I turned water on at the start of the run as soob as the boiler is turned on.

If u are concerned with power usage etc i would turn it on as soon as the thermometer hits 40c. It climbs quickly when it gets to that.
BigRig
 
Posts: 295
Joined: Sun Apr 07, 2019 1:29 pm
Location: Brisbane, QLD
equipment: FSD 4" Mac SSG, 50L Milk Can, 2 x 2400w elements, 35L Digiboil Boiler

Re: First time woes.

Postby pommielad39 » Wed Sep 01, 2021 10:08 am

I was going to get the SS extension tube, but they were out of stock. I turned the water on about 10 mins after I switched on the boiler. Water was pretty cold, i`m in Tassie and it`s been frickin freezing down here. I`ll ditch the plastic, I was only using it due to the position of the still. The water pump is 3600lt ph, but it was only trickling from the outlet, i`m guessing that`s due to the small diameter of the coil?
pommielad39
 
Posts: 8
Joined: Thu Mar 05, 2020 11:03 am
equipment: Reflux condenser on 50L keg boiler.


Return to Beginners Questions



Who is online

Users browsing this forum: Google [Bot] and 10 guests

x